:openbsd.talk

потому что это разные версии пакетов и базовой системы. такое может быть только со снапшотами

в 6.2 python 2.7.14, а не 2.7.14p0, значит это явно не 6.2

снапшоты надо резервировать очень аккуратно, иногда требуется несколько срезов сделать, чтобы версии совпали